[android] 자바 8+ API 디슈가링 지원(Android Gradle 플러그인 4.0.0 이상)

minSDK 버전이 낮지만 LocalDate 같은 걸 쓰는 방법이 있었다.

https://developer.android.com/studio/write/java8-support?hl=ko#library-desugaring

android {
    defaultConfig {
        // Required when setting minSdkVersion to 20 or lower
        multiDexEnabled true
    }

    compileOptions {
        // Flag to enable support for the new language APIs
        coreLibraryDesugaringEnabled true
        // Sets Java compatibility to Java 8
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
}

dependencies {
    coreLibraryDesugaring 'com.android.tools:desugar_jdk_libs:1.1.5'
}